Generic Host Process for Win32 Services

Generic Host Process for Win32 Services

Sungguh meropotkan dan menjengkelkan jika masalah seperti gambar di bawah muncul...



Masalah ini ditimbul karena adanya bugs security pada Windows SP2 bahkan SP3 pun tidak luput dari penyakit ini....
Sungguh aneh Service Pack yang seharusnya membereskan masalah malah memberikan masalah...

Efek dari penyakit ini koneksi internet akan terputus bilapun jalan koneksinya kecepatannya kalah dari jalannya seekor keong.

P3K untuk penyakit ini...

1. download patch di http://gnupg.cdpa.nsysu.edu.tw/Patch/WinXP/en/WindowsXP-KB894391-x86-ENU.exe

2. Blok Port 135 dan 445 (Mainkan registernya)

a.Blok Port 445
- Buka Registry Editor. Lalu ke posisi
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\NetBT\Parameters
cari TransportBindName , semula berisi \Device\ . lalu edit dan kosongkan saja.

b. Blok Port 135
HKEY_LOCAL_MACHINE\Software\Microsoft\OLE

cari EnableDCOM edit value "Y" menjadi "N"

3. Reboot PC anda....


Good luck....kalo ngga berhasil marahin aza Bill Gate







Read more...

jebol password bios

Biar tidak lupa...

C:\>debug

-A

0B05:0100 MOV CX,0

0B05:0103 MOV AX,CX

0B05:0105 OUT 70,AL

0B05:0107 MOV AX,0

0B05:010A OUT 71,AL

0B05:010C INC CX

0B05:010D CMP CX,256

0B05:0111 JB 103

0B05:0113

-G


Read more...

Simple Bridge (Latihan RSTP)

Suatu ketika ada panggilan test disuatu ISP di bandung salah satunya test adalah membuat simple bridge seperti gambar di bawah.

Waktu test aku menggunakan linux dan terus terang ada sedikit kendala karena yang dinilai kecepatan dan ketepatan saat mensetting router2.

di linux kendalanya harus install paket seperti ebstables, bridge-utils, vlan, dll walaupun tinggal
apt-get install lom lagi konfigurasinya yang rada panjang dan modul yang harus diload.



untuk itu aku disuruh nyoba sama sys admin ISP untuk mencoba OpenBSD dan ternyata hasilnya keren banget cepat dan mudah g perlu install apapun karena semua paket telah include ke dalam kernel.

jika ada yang mau nambahin pake linux boleh2 aza di tunggu yaa...




========================== KONFIGURASI =========================

==============================
CORE
==============================

# touch /root/core
# chmod 755 /root/core
# vi /root/core

isikan :

#==========================
# CORE
# aagink@gmail.com
#==========================

echo 'Aktifkan Simple Bridge CORE...'

sysctl net.inet.ip.forwarding=1

lan_if="em0"
vlan_if="vlan10"
vlan_id="10"

vlan_ip="10.10.10.254/24"

ifconfig $lan_if up

ifconfig $vlan_if create vlan $vlan_id vlandev $lan_if
ifconfig $vlan_if up
ifconfig $vlan_if $vlan_ip

# vi /etc/rc.local

tambahkan :

# Add your local startup actions here.

/root/core

echo '.'


# reboot

==============================
CISCO SWITCH
==============================
!
hostname Switch
!
!
!
interface FastEthernet0/1
switchport trunk allowed vlan 10-30
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 10
!
interface FastEthernet0/3
switchport access vlan 20
!
interface FastEthernet0/4
switchport access vlan 30
!

==============================
PC-BRIDGE
==============================

# touch /root/pc-bridge
# chmod 755 /root/pc-bridge
# vi /root/pc-bridge

isikan :

#==========================
# PC-BRIDGE
# aagink@gmail.com
#==========================

echo 'Aktifkan Simple Bridge PC-BRIDGE...'

sysctl net.inet.ip.forwarding=1

if_2_core="em0"
if_2_A="em1"
if_2_B="em2"

if_bridge_2_core="bridge0"
if_bridge_2_router="bridge1"

if_vlan_2_CORE="vlan110"
if_vlan_2_A="vlan210"
if_vlan_2_B="vlan310"

vlan_id="10"

ip_bridge="1.1.1.1/24"

ifconfig $if_2_core up
ifconfig $if_2_A up
ifconfig $if_2_B up

ifconfig $if_bridge_2_core create
ifconfig $if_bridge_2_core up
ifconfig $if_vlan_2_CORE create vlan $vlan_id vlandev $if_2_core
ifconfig $if_vlan_2_A create vlan $vlan_id vlandev $if_2_A
ifconfig $if_vlan_2_B create vlan $vlan_id vlandev $if_2_B
ifconfig $if_vlan_2_CORE up
ifconfig $if_vlan_2_A up
ifconfig $if_vlan_2_B up
brconfig $if_bridge_2_core add $if_vlan_2_CORE
brconfig $if_bridge_2_core add $if_vlan_2_A
brconfig $if_bridge_2_core add $if_vlan_2_B

ifconfig $if_bridge_2_router create
ifconfig $if_bridge_2_router up
brconfig $if_bridge_2_router add $if_2_A add $if_2_B up
ifconfig $if_2_A $ip_bridge


# vi /etc/rc.local

tambahkan :

# Add your local startup actions here.

/root/pc-bridge

echo '.'


# reboot

==============================
ROUTER-A
==============================

# touch /root/router-a
# chmod 755 /root/router-a
# vi /root/router-a

isikan :

#==========================
# ROUTER-A
# aagink@gmail.com
#==========================

echo 'Aktifkan Simple Bridge ROUTER-A...'

sysctl net.inet.ip.forwarding=1

wan_if="em0"
lan_if="em1"

vlan_if="vlan210"
vlan_id="10"

vlan_ip="10.10.10.1/24"
bridge_ip="1.1.1.2/24"
lan_ip="192.168.0.254/24"

ifconfig $wan_if up
ifconfig $lan_if up
ifconfig $wan_if $bridge_ip
ifconfig $lan_if $lan_ip
ifconfig $vlan_if create vlan $vlan_id vlandev $wan_if
ifconfig $vlan_if up
ifconfig $vlan_if $vlan_ip

echo 'Aktifkan PACKET FILLTERING'
pfctl -e
echo
echo 'Aktifkan NAT'
pfctl -Nf /etc/pf.conf

# vi /etc/rc.local

tambahkan :

# Add your local startup actions here.

/root/router-a

echo '.'

membuat NAT

# vi /etc/pf.conf

isikan :

wan_if="vlan210"
lan_if="em1"

nat on $wan_if from $lan_if:network to any -> $wan_if

# reboot

==============================
ROUTER-B
==============================

# touch /root/router-b
# chmod 755 /root/router-b
# vi /root/router-b

isikan :

#==========================
# ROUTER-B
# aagink@gmail.com
#==========================

echo 'Aktifkan Simple Bridge ROUTER-B...'

sysctl net.inet.ip.forwarding=1

wan_if="em0"
lan_if="em1"

vlan_if="vlan310"
vlan_id="10"

vlan_ip="10.10.10.2/24"
bridge_ip="1.1.1.3/24"
lan_ip="192.168.1.254/24"

ifconfig $wan_if up
ifconfig $lan_if up
ifconfig $wan_if $bridge_ip
ifconfig $lan_if $lan_ip
ifconfig $vlan_if create vlan $vlan_id vlandev $wan_if
ifconfig $vlan_if up
ifconfig $vlan_if $vlan_ip

echo 'Aktifkan PACKET FILLTERING'
pfctl -e
echo
echo 'Aktifkan NAT'
pfctl -Nf /etc/pf.conf

# vi /etc/rc.local

tambahkan :

# Add your local startup actions here.

/root/router-b

echo '.'

membuat NAT

# vi /etc/pf.conf

isikan :

wan_if="vlan310"
lan_if="em1"

nat on $wan_if from $lan_if:network to any -> $wan_if


# reboot


Read more...

Install HTB-Tools

Install HTB-Tools
=================

bwm:/# aptitude install shaper
bwm:/tmp# tar zxvf HTB-tools-0.3.0a-i486-1.tgz
bwm:/# mv /tmp/etc/* /etc/
bwm:/# mv /tmp/sbin/* /sbin/
bwm:/# mv /tmp/usr/* /usr/
bwm:/# cp /etc/rc.d/rc.htb.new /etc/init.d/rc.htb
bwm:/# chmod 755 /etc/init.d/rc.htb

Konfigurasi HTB-Tools
=====================


Asumsi :
Bandwidth Total = 2048 kbps
Jumlah Klient = 4 klient
eth0 = upstream
eth1 = downstream

bwm:/# cp /etc/htb/eth0-qos.cfg.new /etc/htb/eth0-qos.cfg
bwm:/# cp /etc/htb/eth1-qos.cfg.new /etc/htb/eth1-qos.cfg

bwm:/# vim /etc/htb/eth0-qos.cfg

isikan dari eth0-qos.cfg

#####################
# eth0-qos.cfg #
#-------------------#
# aagink@gmail.com #
#####################

class class_1 {
bandwidth 2048;
limit 2048;
burst 2;
priority 1;


client PC_1 {
bandwidth 512;
limit 512;
burst 2;
priority 1;
src {
192.168.0.10/32;
};
};

client PC_2 {
bandwidth 512;
limit 512;
burst 2;
priority 1;
src {
192.168.0.20/32;
};
};

client PC_3 {
bandwidth 512;
limit 512;
burst 2;
priority 1;
src {
192.168.0.30/32;
};
};

client PC_4 {
bandwidth 512;
limit 512;
burst 2;
priority 1;
src {
192.168.0.40/32;
};
};
};


class default { bandwidth 8; };


bwm:/# vim /etc/htb/eth1-qos.cfg

isikan dari eth1-qos.cfg

#######################
# eth1-qos.cfg #
#---------------------#
# aagink@gmail.com #
#######################

class class_1 {
bandwidth 2048;
limit 2048;
burst 2;
priority 1;


client PC_1 {
bandwidth 512;
limit 512;
burst 2;
priority 1;
dst {
192.168.0.10/32;
};
};

client PC_2 {
bandwidth 512;
limit 512;
burst 2;
priority 1;
dst {
192.168.0.20/32;
};
};

client PC_3 {
bandwidth 512;
limit 512;
burst 2;
priority 1;
dst {
192.168.0.30/32;
};
};

client PC_4 {
bandwidth 512;
limit 512;
burst 2;
priority 1;
dst {
192.168.0.40/32;
};
};
};


class default { bandwidth 8; };

Cek Konfigurasi
===============

bwm:/# q_checkcfg /etc/htb/eth0-qos.cfg
Default bandwidth: 8

Class class_1, CIR: 2048, MIR: 2048
** 4 clients, CIR2: 2048, MIR2: 2048

1 classes; CIR / MIR = 2048 / 2048; CIR2 / MIR2 = 2048 / 2048

bwm:/# q_checkcfg /etc/htb/eth1-qos.cfg
Default bandwidth: 8

Class class_1, CIR: 2048, MIR: 2048
** 4 clients, CIR2: 2048, MIR2: 2048

1 classes; CIR / MIR = 2048 / 2048; CIR2 / MIR2 = 2048 / 2048


Aktifkan Shaper
===============

bwm:/# /etc/init.d/rc.htb start

Starting HTB-tools on eth0 ...
Checking the config file ...OK
Checking kernel support for HTB: present.
HTB-tools was successfuly started on eth0.


Starting HTB-tools on eth1 ...
Checking the config file ...OK
Checking kernel support for HTB: present.
HTB-tools was successfuly started on eth1.

Liat Trafik
===========

bwm:/# /etc/init.d/rc.htb show_eth0
bwm:/# /etc/init.d/rc.htb show_eth1


Read more...

Singkronisasi Waktu

Untuk mencocokan jam sistem dengan jam hardware
===============================================

Cara 1
------

Jam sistem sebelum di rubah
vpn:/# date
Sat Jan 3 03:54:26 WIT 2009

untuk mencocokan jam sistem dengan jam hardware
vpn:/# hwclock --hctosys --localtime

Jam sistem setelah di rubah
vpn:/# date
Fri Jan 2 20:57:59 WIT 2009

untuk membuat permanen silahkan masukin ke dalam scripts command "hwclock --hctosys --localtime"

Cara 2
------

vpn:/# vim /etc/default/rcS

Isinya harus seperti dibawah ini :

TMPTIME=0
SULOGIN=no
DELAYLOGIN=no
UTC=no
VERBOSE=no
FSCKFIX=no
RAMRUN=no
RAMLOCK=no

vpn:/# reboot

Silahkan cek jam di bios komputer dan di sistem hasilnya pasti sama...

Lumayan menghemat BW karena tidak membutuhkan koneksi ke NTP Server


Read more...

Komentar Anda...

 

Web Stat

Linux Today News Service

My Yahoo Messenger Status

Web Stat